Wemo Smart Plug – Not there yet

I have a love/hate relationship with Belkin’s Wemo products. When they work they work very well but when they decide to misbehave, they are miserable to get working again.

Wemo Smart Switch

I already have 9 Wemo switches in my smart home. These took a long time to settle down but back when I first got them they were at the “bleeding edge” so, like everything else at the time, things were expected to be somewhat rough around the edges.
I credit creating DNS reservations on my router for most of their current stability and improvements in device driver code for much of the rest.

When I added the first of these new smart plugs to the Wemo app it seemed to work perfectly. So I went ahead and added the other two and had them distributed throughout the house.
By the next morning I found the first one was no longer responding (just flashing orange LED) and it had to be reset – after that it worked perfectly, it even integrated with IFTTT just fine.

The other two were not so good, they just kept losing connectivity, regardless of where I located them in the house.

A real deal killer for me, and something I had not initially considered was that these were not recognized by SmartThings (which is not a problem for the Wemo Smart Switches). Likewise, Hubitat Elevation – which was going to be my primary hub for these new plugs – only has a user supported device driver for Wemo switches, dimmers, etc. and these new ones apparently do something funky (respond unexpectedly or on random ports, who knows) such that they cannot be identified for use as a device with this hub.

The real kicker is that, in introducing these to the Wemo app, it started doing all sorts of interesting things both with these plugs and my existing stable of switches. Random switches / plugs would show up as disconnected at different times. Never less than two and typically no more than four even though the switches were still working just fine with my existing hubs.

So I have returned these and am going to instead use Ikea’s Tradfri Wireless Control Outlets. I have 5 of these controlling various lighting fixtures in my house already and do you know what has never given me any problems? These Tradfri outlets! They are somewhat more limited in that they do not have an on/off switch on the unit to override them if things go awry or if you just feel like manually turning something on or off. But I’ve ordered a bunch more and am unlikely to look back at the Wemos for a long long time.

Even now, days after removing these Smart Plugs from my Wemo app, one of my Smart Switches still shows as disconnected, even tough my SmartThings hub can still control it just fine.

tldr; don’t use with SmartThings or Hubitat Elevation and beware the Wemo app. If you do get these working, don’t ever, ever change your setup…

Leave a Reply

Your email address will not be published.