MagicJack + iTunes 9 + Vista Home Premium SP2 = Weird

*Updated September 23, 2009 *

After upgrading to iTunes 9.1 and rebooting, all is well. I’m pretty sure the real issue is the MagicJack. I’m seeing lots of weirdness from it. I’ll play with it for another week and then decide whether to go for Vonage instead. Had trouble verifying my phone in Google Voice. Sometimes I can’t pick up the phone (press 1 when presented with a call from Google voice) other times it picks up but one or the other end of the conversation can’t hear the other.

* End Update *

After performing a bunch of updates on my home machine beginning with the SP2 update for Vista home Premium, I went to play something on my freshly-updated-to-version-9 iTunes and… no sound.

So, while I’m trying to figure out what’s going on with that (all other sounds are playing just fine – media player, streaming videos) Michelle is trying to configure her Google Voice number to point to our new Magic Jack number. When she initiated the verification call to her phone, lo and behold, my iTunes music was playing.

Still trying to work *that* out…

Posted under Groan, Tech Stuff

This post was written by Marc
on September 22, 2009 at 7:59 pm

4,116 views

4 Comments so far

  1. Dave September 22, 2009 8:12 pm

    Wow. Have fun working THAT out!

  2. Marc September 23, 2009 11:07 pm

    After upgrading to iTunes 9.1 and rebooting, all is well. I’m pretty sure the real issue is the MagicJack. I’m seeing lots of weirdness from it. I’ll play with it for another week and then decide whether to go for Vonage instead. Had trouble verifying my phone in Google Voice. Sometimes I can’t pick up the phone (press 1 when presented with a call from Google voice) other times it picks up but one or the other end of the conversation can’t hear the other.

  3. genital warts June 16, 2010 3:15 pm

    magicjack will not work properly with itunes,,it cost me my computor to find that out. of course the magicjack mentions this nowhere in their advertizing.
    delete itunes,reboot and maybe your computor will work again.

  4. towercrane man March 13, 2015 4:03 am

    Yeah i had the same problem

Leave a Comment

Name (required)

Email (required)

Website

Comments

More Blog Posts

Previous Post: